Installing K2 smartforms - Technology tips

Wednesday, December 26, 2012

Installing K2 smartforms

If you come across K2 smartforms which is a latest technology released by SourceCode,  It’s a BPM tool for designing processes spanning people which can design end to end process based on complex business logic.
If you are installing k2 smartforms then you need to understand few more technologies in order to work with K2 designer which is a main component to design end to end processes using k2 Smartform technology like you have to understand Smartobject, views etc.
You will understand the software and hardware requirement for K2 Smartforms and better if you install it on different server and name it as smartform server – and installation process will ask you to identify K2 blackpearl server on this network. But if you are doing some testing then I would say go ahead with existing K2 blackpearl server and run smartform setup from there.
Remember one thing – there is a major component in smartform life-cycle that is K2 Designer you need to remember this component required for smartform technology to run and design process.

Below are hard and software requirement for smartform technology.
In order to install k2 smartforms you need to have K2 Blackpearl 4.6 or greater already installed in your environment.

You need 200 mb to have K2 design time site environment, and for smartform server you need 200 mb of hard drive space.

Software perquisites for K2 smartform server  are , you need to have blackpearl 4.6 or greater already installed.

Microsoft .net framework 3.5 sp1 and Silver-light and Microsoft Visual Studio 2010 web development project- these component are required for K2 Designer to be installed which is component requirement for smartform .

To configure K2 databases you need SQL Server 2008 express, Standard, Enterprise or its sp1 or sp2 or SQL Server 2008 R2 RTM or  SP1 or Microsoft SQL Server 2012.

To configure K2 smartform webpart you need sharepoint foundation, standard, enterprise RTM  or its SP1 or MOSS 2007 Standard, enterprise sp2.

For K2 Designer you need only internet explorer 8 or 9 as a client component and Firefox and Safari or Chrome browser are also supported for K2 designer.

No comments: